Apple、Java 6をサポートする最後のOS X El Capitan向けに「Java for OS X 2015-001」を正式にリリース。


 AppleがJava 6をサポートする最後のOS X El Capitan向けに「Java for OS X 2015-001」を公開しています。詳細は以下から。


 Appleは「OS X 10.11 El CapitanをOracleが2013年にサポートを打ち切ったJava 6のサポートする最後のOS Xとする」と開発者向けに発表しており、Adobe CSやFlash Builder, Eclipseユーザーが対応を求められています。


Note:OS X El Capitan is the last major release of OS X that will support the previously deprecated Java 6 runtime and tools provided by Apple. Applications or features that depend upon Java 6 may not function properly or will not launch when Java 6 is removed. Developers should move to a newer version of Java as provided by Oracle. For more info on Java from Oracle:

[OS X v10.11 Release Notes – Apple Developer]

 Appleはこれに伴い、OS X 10.11 El Capitan Developer Beta 3/Public Beta 1リリース時にEl Capitan向けの”Java for OS X 2015-001 Beta”をリリースしていましたが、DB 4/PB 2リリース後これを”Java for OS X 2015-001”として正式に配布しています。


Java for OS X 2015-001 installs the legacy Java 6 runtime for OS X 10.11 El Capitan, OS X 10.10 Yosemite, OS X 10.9 Mavericks, OS X 10.8 Mountain Lion, and OS X 10.7 Lion.

This package is exclusively intended for support of legacy software and installs the same deprecated version of Java 6 included in the 2014-001 and 2013-005 releases. Quit any Java applications before installing this update.

Please quit any Java applications before installing this update.

[Java for OS X 2015-001 – Apple]

 Java for OS X 2015-001はレガシーな Java SE 6ランタイムがインストールされ、OS X 10.7 LionからOS X 10.11 El Capitanで使用可能。サポートサイトのURLが”Java for OS X 2014-001″と同じで、現在 日本語のサポートページは更新されていないので必要な方は下記リンクからどうぞ。