2012年製以前のMacや古いBoot Campを利用していると「Windows 10 version 1903」アップデートが適用できないケースがあるとしてMicrosoftがサポートドキュメントを公開。

スポンサーリンク

 2012年製より前のMacや古いBoot Campを利用していると「Windows 10 version 1903」アップデートが適用できないケースがあるとしてMicrosoftがサポートドキュメントを公開しています。詳細は以下から。


 Microsoftは現地時間2019年07月02日、05月に提供を開始した「Windows 10 May 2019 Update (version 1903)」をBoot Campを利用してMacにインストールしたWindows 10に適用しようとすると、MacHALDriver.sys (HALはHardware Abstraction Layer)に互換性の問題が発生しアップデートできない場合があるとしてサポートドキュメントを公開しています。

Windows 10 version 1903 and before 2012 Mac issue

Symptoms
If you are trying to update to the May 2019 Feature Update for Windows 10 (Windows 10, version 1903), you may experience an update compatbility hold and receive the message, “Mac HAL Driver – machaldriver.sys: Your PC has a driver or service that isn’t ready for this version of Windows 10.”

Updating to Windows 10, version 1903 on Apple Mac devices introduced before 2012 or newer Mac devices with older versions Apple Boot Camp or Windows Support Software drivers installed – Microsoft

スポンサーリンク

対象のMac

 この問題は2012年以前に製造されたMacにインストールしたWindows 10や、古いApple Boot Camp Assistantを利用してインストールしたWindows 10で発生しており、”Windows\system32\drivers”フォルダに”September 24, 2011 01:57:09″付のMacHALDriver.sysが存在すると問題が発生するため、一度macOSを起動してAppleメニューからAppleが提供するソフトウェア・アップデートを全て適用すると解決する場合があるとしています。

MacHALDriver.sys

 Microsoftは2019年07月末に提供するアップデートでこの問題を解決する方向で動いているようですが、Appleは2018年にリリースしたmacOS 10.14 Mojaveでシステム要件を2012年以降のMacとしたため、この問題が発生しているMacは来年のmacOS 10.16のリリースと同時にセキュリティアップデートが提供されなくなると思われるため、ユーザーの方は注意してください。

Windows 10, version 1903

macOS 10.12 Sierra
macOS 10.13 High Sierra
macOS 10.14
Mojave
macOS 10.15
Catalina
MacBook Late 2009以降 2015以降
MacBook Air Mid 2010以降 2012以降
MacBook Pro Late 2010以降
Mac mini Mid 2010以降
iMac Late 2009以降
iMac Pro macOS 10.13.2以降 2017以降
Mac Pro Mid 2010以降 Mid 2010
Mid 2012以降
2013以降

コメント

  1. 匿名 より:

    MacPro 2009でBootcampを使ってWindows10を動かしていますが、そろそろやめた方がよさそうですね。

  2. どんがめ より:

    古いBootCampでwindows7から10にアップグレードしてるケース、あるとおもいます!

  3. 匿名 より:

    2012年モデルを切り捨てるとかMSは悪魔だな

    • 匿名 より:

      別に切ってるわけじゃないでしょ。
      Appleが更新しないのが悪いんじゃない。
      問題が起きないようにMSがブロックしてるから、むしろ親切じゃない。

  4. 匿名 より:

    そもそもWindows10に上げてもソフトウェアアップデートが対応してくれないんじゃなかったっけ
    iMacのmid2011とか

  5. 岡里名桜 より:

    Mac mini mid 2011とMacBook Early 2008のBootCamp環境で、ようやく1903にアップデートできるようになりました。