Google ChromeをOS X Yosemiteで使用した際にアクティビティモニタに表示される「Helper(応答なし)」は表示上のバグでパフォーマンスには影響しないもよう。

スポンサーリンク

 Google ChromeをOS X Yosemiteで使用した際にアクティビティモニタの表示に不具合があるようです。詳細は以下から。


Google-Chrome-on-Yosemite-Activity-Monitor


 OS X Yosemiteにアップグレード後、Google Chromeブラウザを使用中にアクティビティモニターを確認すると「Google Chrome Helperというプロセスが(応答なし)という表示を出している」という報告がChrome Help Forum[1]やIssue Forum[397642]、Hacker Newsなどに寄せられていますが、この不具合はCPU使用率に影響を与えておらず表示上のミス(不具合)のようで、GoogleのSarah Deeさんは

Hi All,

Thanks for your patience. I wanted to provide an update.
>お待たせしてすみません。私はアップデートを提供したかった。

To start, there are many different issues being brought up in this thread.
>まず始めに、このスレッドには様々な複数の不具合が投稿されています。


To address the primary issue of the activity monitor showing messages that “Google Chrome Helper Not Responding” is purely a cosmetic bug and is not affecting the actual performance of Chrome.

>アクティビティモニターに表示される「Google Chrome Helper(応答なし)」というメッセージの不具合は単純な表示上のバグ”cosmetic bug”で、これはChromeのパフォーマンスに影響を与えません。

We know that showing this message when nothing is going wrong is a bad user experience, so have identified and provided a solution—this is now live in the newest versions of Chrome in Dev and Canary, but will not be available in the stable version until version 40 (we are currently on version 40).
>我々はこのメッセージが悪いUXであることを知っており、既に問題を特定し解決したものをChrome DevバージョンとCanaryで提供しています。
(略)
I’ll update you all here when I get any new news.
>また何か新しい進展がありましたらここで報告します。

Best,
Sarah

[Google Chrome Helper (Not Responding) on OSX Yosemite]

とコメントしており、他のスレッドに投稿されたアクティビティモニターの詳細を見てもCPUやメモリ使用率が低いことから単なる表示上のバグである場合が多いようです。


10

That process is definitely not hung. Would you mind sampling another one, perhaps one that’s sitting at 0% CPU usage?

>このプロセスはハングアップしていません。他のものもサンプリングして頂けませんか?多分他のものもCPU使用率が0%になっていると思います。

 アクティビティモニターを見て実際にGoogle ChromeのCPUやメモリ使用率が高い場合は別の不具合である可能性があるのでChrome Canary Buildを使用してみるか、同様の不具合をIssue Forumで確認してみてください。

関連リンク:
Canary ブラウザ – Google

Issue 397642: Google Chrome Helper (not responding) on Yosemite

コメント

  1. Apple7743 より:

    気になってたけどそういうことだったのね。

  2. Apple7743 より:

    Chromiumを使えばいいのに、なんでChrome使うのかね?

  3. Apple7743 より:

    cosmetic bugてバグの種類あるのか

  4. Apple7743 より:

    ※2
    どっちも同じ症状。
    ちなみにこれは今までもずっと応答なしになっている。
    マベまでは無問題だったけど、yosemiteのはどうもマジで悪影響を及ぼしている様なんだよね。
    ChromeでもChromiumでも立ち上げるとWindowserverが暴走する感じがする。
    ChromeとChromiumを使わないとならない。
    だから自分はとりあえずしばらくChrome系を使わないことに決めた。

  5. Apple7743 より:

    topで見たらこの手のバグ多そうな印象

  6. Apple7743 より:

    Chromium 38.0.2125.111 (290379) だが、何も起きないぞ
    特定機種とその組み合わせバグか?

  7. Apple7743 より:

    Chromeがメモリを使いすぎるバグも修正はよ

  8. Apple7743 より:

    ※6
    同じ環境しているはずの2台、一台はC2D2.4Mhz, 8G. 9400MのMBとi7, 16G, HD6630Mのmac mini
    同じデルのU2713HにつなげてみてもロートルMBでChromium使っても透明度下げなくてもWindowServerは暴走せず普通に使えるがmac miniの方で起動直後は大丈夫なのにChromiumを使うと透明度を下げないとすぐにカクカクで全く使い物にならない。
    両方共入っている機能拡張も設定も全く同じ。
    なんでなんだろう・・・。

  9. Apple7743 より:

    助けを呼んでも応答がない